Enterprise Customers Upgrading Recast Server 3.2 to 4.0

Upgrading from 3.2 to 4.0 has some special steps to get you upgraded.  Due to the large infrastructure changes, and new features in 4.0, a simple upgrade, migrating settings just isn't possible.  

Items that don't migrate: permissions/roles, lab manager profile (now renamed Kiosk manager), and Builder actions.  In order to help recreate them in 4.0, we recommend you document the permissions and export the lab/kiosk and Builder items before the upgrade. Then load them into a 3.2 standalone enterprise install afterwards, so you can reference them when you recreate them on 4.0.

Good news, future releases will be the simple upgrade.  Before going much further, the official docs for the Installation of 4.0 are here, along with detailed info.

Lets do a quick reminder of the backend differences:

Recast Enterprise Server 3.2 Control Panel


Enterprise Server 4.0 Admin Center (Browser Based)

Starting the Upgrade, if running on the same server, you'll notice right off the bat additional Pre-Reqs are needed to support 4.0.  
Pre-Reqs:
Recast Server requires a domain joined Windows Server 2008 R2 or later server for installation with IIS enabled, the .NET Core Hosting Bundle needs to be installed, and a SQL Server Express (or better) server needs to be available. If the .NET Core Hosting Bundle was installed before IIS was installed, you will need to repair the .NET Core Hosting Bundle installation.

On my Recast 3.2 Server, before starting the upgrade, I already installed SQL Server 2017 Express LocalDB and SQL Server Management Studio [OPTIONAL] to manage the Database.  I also installed the IIS Feature. [which was already installed because this server doubles as a ConfigMgr Management Point]

Now I'll install the other Pre-Reqs, clicking the Link brings up the website, launching the installer, then checking the box and clicking "Install"

Now that .Net Core is installed, re-launch the Installer, and follow the Prompts

I choose to re-use the Cert from when 3.2 was installed.
Reminder, I'm using SQL Express on local machine, if you use Remote SQL, you'll need to change this.  Make sure you read the words on the dialog boxes.

Make sure the "Test SQL Connection" returns "Success"

After installing, you can see 3.2 is no longer installed.  The 4.0 Installer removed 3.2.

After the Install is finished, it will prompt for Reboot, which is highly recommend.  If you don't and you launch the web console, you'll find yourself quite annoyed at the behavior of being prompted over and over again for creds.  Just reboot and save yourself a little frustration.
Once rebooted, go ahead and launch the Browser Based Console (From any machine that can connect to port 444 on the Recast Management Server)

Things to Note:

Community Tool: ConfigMgr Prerequisites Tool

If you have any questions, or want to discuss your upgrade or install before you make the jump, please contact support and schedule a time to cover them.